i 指标公式,股票指标公式,技术指标,本栏目包含指标公式,股票指标公式,技术指标等内容
返回首页-庄家事儿网
.
当前位置:红岭私募 > 技术指标

公式-祝贺“五里头”出任《指标与实战实验区》班长!(出任)

关键字:指标公式,股票指标公式,技术指标  来源:红岭私募网hlsm.net
祝贺“五里头”《指标与实战实验区》班长,望“五里头”再接再厉,更好服务于广大会员!特发一个【自用KDJ】指标,指标中KQ、DQ、JQ指标线近似于KDJ指标的周线,为了排除小周期引用大周期带来的未来性质,我用计算出来的综合数值4.4倍进行代替,所以说只是近似于周线,指标中的同底、同金的选股公式已经开通,可以直接进行选股!
引用:
{【自用KDJ】}
input:n(9,1,100),n1(3,1,100),n2(3,1,100);
RSVq:=(CLOSE-LLV(LOW,INTPART(N*4.4)))/(HHV(HIGH,INTPART(N*4.4))-LLV(LOW,INTPART(N*4.4)))*100;
Kq:SMA(RSVq,INTPART(N1*4.4),4),linethick2,Color006FDD;
Dq:SMA(Kq,INTPART(N2*4.4),4),linethick2,Color009F00;
Jq:3*Kq-2*Dq,linethick,ColorABAB56;
PARTLINE(Kq>dq,dq),linethick2,Color006FDD;
PARTLINE(Kq<dq,Kq),linethick2,Color009F00;
STICKLINE(Kq>=dq,Kq,dq,1,0),Color006FDD;
STICKLINE(Kq<dq,Kq,dq,1,0),Color009F00;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:EMA(RSV,N1),linethick1,ColorFF00FF;
D:EMA(K,N2),linethick1,Color00A6A6;
J:3*K-2*D,linethick,ColorFF8080;
PARTLINE(K<d ,K),ColorFF8000,linethick1;
同金:cross(k,d) and cross(kq,dq)  and k>kq,linethick;
长短同金:VERTLINE(同金),LINEDOT,Color808080;
同底:J<0 AND Jq<0,linethick;
长短同底:DRAWICON(同底,0,8),Color0000FF,align0;
同顶:J>100 AND Jq>100,linethick;
长短同顶:DRAWICON(同顶,100,9),Color00FF00,align0;    
飞狐粘贴源码出现错误的,可直接下载公式文件进行导入;
【自用KDJ】.ALG (1.92 KB) 【自用KDJ】.ALG (1.92 KB)
下载次数: 453
2009-4-11 14:25
1.jpg (109.75 KB)
2009-4-11 11:27

下面源码通达信可用!
引用:
{参数:N(1,100,9),N1(1,100,3),N2(1,100,3);}
RSVQ:=(CLOSE-LLV(LOW,INTPART(N*4.4)))/(HHV(HIGH,INTPART(N*4.4))-LLV(LOW,INTPART(N*4.4)))*100;
KQ:SMA(RSVQ,INTPART(N1*4.4),4),LINETHICK2,COLOR006FDD;
DQ:SMA(KQ,INTPART(N2*4.4),4),LINETHICK2,COLOR009F00;
JQ:3*KQ-2*DQ,LINETHICK,COLORABAB56;
IF(KQ>DQ,DQ,DRAWNULL),LINETHICK2,COLOR006FDD;
IF(KQ<DQ,KQ,DRAWNULL),LINETHICK2,COLOR009F00;
STICKLINE(KQ>=DQ,KQ,DQ,0.5,0),COLOR006FDD;
STICKLINE(KQ<DQ,KQ,DQ,0.5,0),COLOR009F00;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:EMA(RSV,N1),LINETHICK1,COLORFF00FF;
D:EMA(K,N2),LINETHICK1,COLOR00A6A6;
J:3*K-2*D,LINETHICK,COLORFF8080;
IF(K<D ,K,DRAWNULL),COLORFF8000,LINETHICK1;
同金:CROSS(K,D) AND CROSS(KQ,DQ)  AND K>KQ,LINETHICK;
长短同金:STICKLINE(同金,5,95,0.1,0),COLOR808080;
同底:J<0 AND JQ<0,LINETHICK;
长短同底:DRAWICON(同底,0,11),COLOR0000FF;
同顶:J>100 AND JQ>100,LINETHICK;
长短同顶:DRAWICON(同顶,100,12),COLOR00FF00;    
1.jpg (124.39 KB)
2009-4-11 14:27

股票公式 www.hlsm.net

  声明:本站部分内容来自合作媒体及网络,不代表本站观点。本站不对上述言论承担责任。关键字:长短,指标,自用,公式,引用

大智慧公式网部分资料来自网络,版权归原作者所有.关键字:指标公式,股票指标公式,技术指标