i 指标公式破解,指标公式编写,股票指标公式,本栏目包含指标公式破解,指标公式编写,股票指标公式等内容
返回首页-庄家事儿网
.
当前位置:红岭私募 > 指标公式教程

源码-金融投资家”软件原码:(金融)

关键字:指标公式破解,指标公式编写,股票指标公式  来源:红岭私募网hlsm.net
金融投资家”软件原码:
天麒二弹  20天10%成功率99.474%
Var1:=IF(EMA(CLOSE,5)/EMA(EMA(CLOSE,9),16)<=0.85 AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,50,0);
Var2:=(-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100;
Var3:=(-100)*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;
Var4:=(-100)*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100;
Var5:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;
Var6:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;
Var7:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;
Var8:=(Var2+Var3+Var4+Var5+Var6+Var7)/6;
Var9:=EMA(Var8,3);
VarA:=ABS(Var5-Var7);
VarB:=(Var8+VarA)/2;
VarC:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50;
VarD:=VarC+VarB;
VarE:=IF(Var1>0 AND VarD<0,200,0);
VarF:=IF(VarB<0 AND CLOSE=LLV(CLOSE,5) AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,-50,0);
Var10:=IF(VarD<0 AND VarF=-50,100,0);
Var11:=MA(CLOSE,3);
Var12:=REF(CLOSE,2)*0.865;
Var13:=REF(CLOSE,13)*0.772;
Var14:=MIN(Var12,Var13);
Var15:=100*VOL/CAPITAL;
Var16:=MA(CLOSE,13);
Var17:=IF((CLOSE-Var14)/CLOSE<0.03 AND SUM(Var15,5)/5<1.8,1,0);
Var18:=IF(Var17>0 AND (VarF<0 OR Var1>0),100,0);
Var19:=Var18;
Var1A:=IF(VarE>0 AND Var10>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var17>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902 OR (VarE>0 AND Var10>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var17>0) AND (VarF<0 OR Var1>0) AND Var18<10,50,0);
Var1B:=(VarE>0 AND Var10>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var17>0) AND (VarF<0 OR Var1>0);
Var1C:=VarE>0 AND Var10>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var17>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902;
Var1D:=Var1B OR Var1C;
Var1E:=MA(CLOSE,80)-MA(CLOSE,10)/3;
Var1F:=Var19 AND CLOSE<Var1E;
Var20:=1;
Var21:=Var20*(CLOSE-MA(CLOSE,33))/MA(CLOSE,33)*100;
Var22:=HHV(CLOSE,13)/CLOSE>1.15 AND HIGH/LOW>1.08 AND CROSS(-30,Var2);
Var23:=INDEXC;
Var24:=MA(Var23,6);
Var25:=MA(Var23,24);
Var26:=MA(Var23,32);
Var27:=MA(Var23,62);
Var28:=MA(Var23,105);
Var29:=Var27<REF(Var27,1) AND Var28<REF(Var28,1) AND Var27<Var28*0.98;
Var2A:=Var26>Var24*1.11 AND Var25>Var24*1.095;
Var2B:=Var24>Var23*0.95;
Var2C:=Var29 AND Var2A AND Var2B AND CLOSE/COST(8)<=0.8 AND (CLOSE>OPEN OR CLOSE<OPEN) AND (REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1));
Var2D:=DMA(CLOSE,VOL/MA(VOL,4)/4);
Var2E:=DMA(CLOSE,VOL/MA(VOL,33)/33);
Var2F:=(CLOSE-Var2D)/Var2D*100<-11;
Var30:=(Var2D-Var2E)/Var2E*100<-22.3;
Var31:=Var2F AND Var30;
Var32:=Var31 AND (OPEN>CLOSE OR OPEN<CLOSE) AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.07 AND (REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1)) AND (REF(OPEN,2)>REF(CLOSE,2) OR REF(OPEN,2)<REF(CLOSE,2)) AND (REF(OPEN,3)>REF(CLOSE,3) OR REF(OPEN,3)<REF(CLOSE,3)) AND (REF(OPEN,4)>REF(CLOSE,4) OR REF(OPEN,4)<REF(CLOSE,4)) AND (REF(OPEN,5)>REF(CLOSE,5) OR REF(OPEN,5)<REF(CLOSE,5)) AND (REF(OPEN,6)>REF(CLOSE,6) OR REF(OPEN,6)<REF(CLOSE,6)) AND (REF(OPEN,7)>REF(CLOSE,7) OR REF(OPEN,7)<REF(CLOSE,7));
Var33:=INDEXC;
Var34:=MA(Var33,5);
Var35:=MA(Var33,20);
Var36:=MA(Var33,30);
Var37:=Var36>Var34*1.08 AND Var35>Var34*1.055;
Var38:=Var34>Var33*1.03;
Var39:=Var37 AND Var38;
Var3A:=MA(CLOSE,5);
Var3B:=MA(CLOSE,10);
Var3C:=Var3A<Var3B;
Var3D:=(Var3A-CLOSE)/CLOSE>0.09;
Var3E:=(Var3B-Var3A)/Var3A>0.05;
Var3F:=HIGH>LOW*1.07 AND COUNT(HIGH>LOW*1.04,5)>2;
Var40:=COUNT(Var3C,7)>=7;
Var41:=Var3D AND Var3E AND Var3F AND Var40;
Var42:=Var39 AND Var41;
Var43:=(REF(CLOSE,32)-CLOSE)/REF(CLOSE,32)>=0.385;
Var44:=Var2C AND Var43;
Var45:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
Var46:=(CLOSE-Var45)/Var45*100+30-(REF(HIGH,13)/CLOSE-1.35)*100;
Var47:=(CLOSE-REF(CLOSE,5))/CLOSE*100<-9;
Var48:=WINNER(CLOSE);
Var49:=EMA((INDEXC-MA(INDEXC,10))/INDEXC*100,14)<-4.9;
Var4A:=(MA(VOL,5)-VOL)/CAPITAL*100<0.8;
Var4B:=(VOL-MA(VOL,21))/VOL*100;
Var4C:=Var49 AND Var47 AND Var48<0.12 AND Var4A AND Var4B>18;
Var4D:=Var49 AND Var47 AND Var48<0.12 AND Var4A AND Var4B>18;
Var4E:=Var1F AND Var4D;
Var1F AND Var22 OR Var1F AND Var2C OR Var1F AND Var32 OR Var1F AND Var42 OR Var44 OR Var4E;

天麒一弹 20天10%成功率92%
Var1:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,5);
Var2:=INDEXC;
Var3:=MA(Var2,5);
Var4:=MA(Var2,20);
Var5:=MA(Var2,30);
Var6:=Var5>Var3*1.08 AND Var4>Var3*1.055;
Var7:=Var3>Var2*1.03 AND Var4>Var2*1.13;
Var8:=Var7;
Var9:=IF(FILTER(Var1<6,5)=1,1,0);
VarA:=Var1<6 AND Var8;
点股成金2: IF(FILTER(VarA,1)=1,1,0);

天麒一星 20天10%成功率88%
选ST股1:= STRNCMP(STKNAME, 'ST', 2)=0; //表示该股为ST股;
选ST股2:= STRNCMP(STKNAME, '*ST', 2)=0; //表示该股为*ST股;
选ST股:=选ST股1 OR 选ST股2;
滤掉ST股:=选ST股=0;

Var1:=MA(CLOSE,80)-MA(CLOSE,10)/3;
Var2:=CLOSE<Var1 AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3;
Var3:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
Var4:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
Var5:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
Var6:=REF(CLOSE,1);
Var7:=SMA(MAX(CLOSE-Var6,0),5,1)/SMA(ABS(CLOSE-Var6),5,1)*100;
Var8:=(HIGH+LOW+CLOSE)/3;
Var9:=(Var8-MA(Var8,14))/(0.015*AVEDEV(Var8,14));
VarA:=Var3>=-15.8 AND Var3<=-12.2 AND Var4<=-20.8 AND Var5<=-27.5 AND Var7<=11.7 AND Var9<=-145;
VarB:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100<-8 AND REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
VarC:=REF(CLOSE,1);
VarD:=SMA(MAX(CLOSE-VarC,0),6,1)/SMA(ABS(CLOSE-VarC),6,1)*100;
VarE:=SMA(MAX(CLOSE-VarC,0),12,1)/SMA(ABS(CLOSE-VarC),12,1)*100;
VarF:=BARSLAST(VarE<20)<=3 AND CROSS(VarD,VarE);
Var10:=(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100<-12.5;
Var11:=LLV(LOW,5);
Var12:=HHV(HIGH,5);
Var13:=EMA((CLOSE-Var11)/(Var12-Var11)*100,4);
Var14:=EMA(0.667*REF(Var13,1)+0.333*Var13,2);
Var15:=VarF AND Var10 AND CROSS(Var13,Var14) AND Var13<=25;
Var16:=(REF(CLOSE,1)+REF(CLOSE,2)+REF(CLOSE,3)+REF(CLOSE,4)+REF(CLOSE,5))/5;
Var17:=(REF(CLOSE,2)+REF(CLOSE,3)+REF(CLOSE,4)+REF(CLOSE,5)+REF(CLOSE,6))/5;
Var18:=(REF(CLOSE,3)+REF(CLOSE,4)+REF(CLOSE,5)+REF(CLOSE,6)+REF(CLOSE,7))/5;
Var19:=(REF(CLOSE,4)+REF(CLOSE,5)+REF(CLOSE,6)+REF(CLOSE,7)+REF(CLOSE,8))/5;
Var1A:=(REF(CLOSE,5)+REF(CLOSE,6)+REF(CLOSE,7)+REF(CLOSE,8)+REF(CLOSE,9))/5;
Var1B:=(Var16/CLOSE>1.112 OR Var17/CLOSE>1.123 OR Var18/CLOSE>1.135 OR Var19/CLOSE>1.145 OR Var1A/CLOSE>1.156) AND (CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100<=-20 AND COST(25)/CLOSE>=1.5;
Var1C:=(VarA OR Var2 OR VarB OR Var15 OR Var1B) ;
IF(Var1C,MA(CLOSE,60)-CLOSE,0) and 滤掉ST股;

天麒二星  5天5%成功率81%
Var1:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100;
Var2:=SMA(Var1,2,1);
Var3:=SMA(Var2,3,1);
Var4:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
Var5:=SMA(Var4,2,1);
Var6:=SMA(Var5,3,1);
Var7:=(CLOSE-LLV(LOW,3))/(HHV(HIGH,3)-LLV(LOW,3))*100;
Var8:=SMA(Var7,2,1);
Var9:=SMA(Var8,5,1);
VarA:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VarB:=SMA(VarA,2,1);
VarC:=SMA(VarB,5,1);
VarD:=3*VarB-2*VarC;
CLOSE>=HHV(HIGH,110) AND CLOSE/CLOSE>LOW AND CLOSE/REF(CLOSE,1)>1.011 OR Var2<21 AND
Var5>Var3 AND REF(VOL,2)>REF(VOL,7) AND VOL>REF(VOL,LOW) AND CLOSE>MA(CLOSE,2) AND OPEN>REF(CLOSE,1)

AND CLOSE/LOW>1.097 OR REF(CLOSE,1)<MA(CLOSE,12) AND MA(CLOSE,13)/MA(CLOSE,16)>1.005 AND MA(CLOSE,11)>MA(CLOSE,14)

AND CLOSE>=HHV(HIGH,3) AND CLOSE/LOW>1.098 AND REF(VOL,1)>REF(VOL,7) OR REF(HIGH,1)<REF(LOW,101) AND LOW/REF(LOW,1)>1.2

AND CLOSE>=HHV(HIGH,7) OR REF(HIGH,55)<REF(LOW,123) AND REF(HIGH,35)<REF(LOW,55) AND REF(HIGH,21)<REF(LOW,35)

AND REF(HIGH,13)>REF(LOW,21) AND REF(CLOSE,3)>REF(CLOSE,123) AND CLOSE/OPEN>1.074 OR MA(CLOSE,2)>MA(CLOSE,4)

AND MA(CLOSE,4)>MA(CLOSE,8) AND CLOSE>=HHV(HIGH,1) AND BARSCOUNT(CLOSE)>588 AND CLOSE/LOW>1.196

AND CLOSE/REF(CLOSE,2)>1.09 OR Var9>96.1 AND CLOSE/REF(CLOSE,1)>1.034 OR VarD>118 AND Var9>87.9

AND CLOSE/REF(CLOSE,2)>1.101 OR LOW/LOW/REF(CLOSE,LOW)>1.038 AND LOW/REF(CLOSE,LOW)>1.01

AND LOW<REF(LOW,55) OR REF(CLOSE,LOW)<MA(CLOSE,16) AND MA(CLOSE,14)/MA(CLOSE,15)>1.004

AND MA(CLOSE,7)>MA(CLOSE,14) AND CLOSE>=HHV(HIGH,8) AND REF(VOL,LOW)>REF(VOL,1) AND CLOSE/REF(CLOSE,1)>1.048

AND CLOSE/LOW>1.101 OR (CLOSE-MA(CLOSE,15))/MA(CLOSE,15)*80<-13 AND VarB<16 AND VarB>VarC AND CLOSE/LOW>1.045 AND BARSCOUNT(CLOSE)>495;

天麒三星 5天5%成功率87%
Var1B:=MA(CLOSE,80)-MA(CLOSE,10)/3;
Var1C:CLOSE<Var1B AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3;

股票公式 www.hlsm.net

  声明:本站部分内容来自合作媒体及网络,不代表本站观点。本站不对上述言论承担责任。关键字:三星,成功率,该股,公式,股票

大智慧公式网部分资料来自网络,版权归原作者所有.关键字:指标公式破解,指标公式编写,股票指标公式