i 指标公式破解,指标公式编写,股票指标公式,本栏目包含指标公式破解,指标公式编写,股票指标公式等内容
返回首页-庄家事儿网
.
当前位置:红岭私募 > 指标公式教程

源码-请各位版主和各位高手把下面的四个飞狐公式改成一个为大智慧的指标公式(手把)

关键字:指标公式破解,指标公式编写,股票指标公式  来源:红岭私募网hlsm.net
请各位版主和各位高手把下面的四个飞狐公式改成一个为大智慧的指标公式

一目

阻力线:llv(llv(hhv(h,11),11),11),COLORGREEN,LINETHICK5;

重要转折线:hhv(hhv(llv(l,11),11),11),COLORBLUE,LINETHICK3;
十日高:hhv(high,10)*(1-5/100),COLORBLUE,linethick2;
重要支承:llv(low,10)*(1+5/100),,COLOR1199ff,linethick3;
llv(llv(hhv(h,11),11),11),COLORBROWN,LINETHICK2;
llv(low,10)*(1+5/100),COLORGREEN,linethick1;
hhv(hhv(llv(l,11),11),11),COLORBROWN,LINETHICK5;
hhv(hhv(llv(l,11),11),11),COLORCYAN,LINETHICK4;
hhv(hhv(llv(l,11),11),11),COLORCYAN,LINETHICK3;
hhv(hhv(llv(l,11),11),11),COLORBROWN,LINETHICK2;
hhv(hhv(llv(l,11),11),11),COLORRED,LINETHICK1;

{MACD}

INPUT:N1(3,1,100),N2(10,1,100),N3(10,1,100),N4(20,1,100),M(9,1,100);
{短波}
短波EMA(C,N1)-EMA(C,N2))*300,LINETHICK0,COLORRED;
短均线:EMA(短波,M),LINETHICK0,COLORCYAN;
MACD:=2*(短波-短均线);
{中波}
中波EMA(C,N3)-EMA(C,N4))*300,COLORYELLOW;
中均线:EMA(中波,M),COLORBLUE;
MACD2:2*(中波-中均线),LINETHICK1;
STICKLINE(MACD2>=0,MACD2,0,2,1),COLORMAGENTA;
STICKLINE(MACD2<0,MACD2,0,2,1),COLORWHITE;
{绘图}
FILLRGN(中波>=中均线,中波,中均线),COLORYELLOW;
FILLRGN(中波<中均线,中波,中均线),COLORBLUE;
{FILLRGN(短波>=短均线,短波,短均线),COLORRED;
FILLRGN(短波<短均线,短波,短均线),COLORGREEN;}
短均线,LINETHICK2,COLORCYAN;
PARTLINE(短波>=短均线,短波),COLORRED,LINETHICK2;
PARTLINE(短波<短均线,短波),COLORGREEN,LINETHICK2;
{周金叉,死叉}
AA:="MACD.DIFF#WEEK";
BB:="MACD.DEA#WEEK";
周金叉:IF(CROSS(AA,BB),160,0),colorred;
周死叉:IF(CROSS(BB,AA),160,0), COLORBLUE;
DRAWTEXT(周金叉,160,'周金叉'), ALIGN,colorred;
DRAWTEXT(周死叉,160,'周死叉'), ALIGN, COLORBLUE;
{月金叉,死叉}
CC:="MACD.DIFF#MONTH";
DD:="MACD.DEA#MONTH";
月金叉:IF(CROSS(CC,DD),185,0), ALIGN,Color0080FF;
月死叉:IF(CROSS(DD,CC),185,0), ALIGN,Colorblue;
DRAWTEXT(月金叉,185, '月金叉'),ALIGN,COLORyellow;
DRAWTEXT(月死叉,185,'月死叉'),ALIGN,COLORBLUE;
{选股}
EE:=CROSS(中波,中均线) AND MACD2>REF(MACD2,1) AND 短波>=REF(短波,1) AND 中均线>=REF(中均线,1);
出来:FILTER(EE,10);
DRAWICON(出来,中均线,1);



一目

N:52 ,0,100 m:26,0,100 L:9,0,100
STICKLINE(open>=close ,close ,open,9,0 ),COLORaaaaaa;
STICKLINE(open>=close ,close ,open,6,0 ),COLORbbbbbb;
STICKLINE(open>=close ,close ,open,2.4,0 ),COLORcccccc;
STICKLINE(open>=close ,close ,open,1.1,0 ),COLOR;

STICKLINE(close>open,close,open,9,0 ),COLOr6666cc;
STICKLINE(close>open,close,open,6 ,0 ),COLOR7777dd;
STICKLINE(close>open,close,open,2.4 ,0 ),COLOR8888ee;
STICKLINE(close>open,close,open,1.1 ,0 ),COLOR9999ff;

STICKLINE(close>open,open,low,0.5,0 ),COLOR1199ff;
STICKLINE(close>open,close,HIGH,0.5 ,0 ),COLOR1199ff;
STICKLINE(open>=close,close,low,0.5 ,0 ),COLORcccccc;
STICKLINE(open>=close,open,HIGH,0.5 ,0 ),COLORcccccc;
基準線:(HHV(H,26)+LLV(l,26))/2,LINETHICK2,COLORGREEN;



天网
{N,10  1   100}
CG:ma((LOW+HIGH+CLOSE*2)/4,n);
FL:hhv(CG,3),COLORgreen,POINTDOT;
FS:if(CG<FL,(CG-(FL-CG)),FL),COLORgreen;
FL1:hhv(CG,5),COLORgreen,POINTDOT;
FS1:if(CG<FL1,(CG-(FL1-CG)),FL1),COLORgreen;
FL2:hhv(CG,7),COLORgreen,POINTDOT;
FS2:if(CG<FL2,(CG-(FL2-CG)),FL2),COLORgreen;
FL3:hhv(CG,9),colorFFABA3,linethick2;
FS3:if(CG<FL3,(CG-(FL3-CG)),FL3),colorFFABA3,linethick2;
zlzc1:=(hhv(h,144)-((hhv(h,144)-llv(l,144))*0.618));
zlzc2:=(hhv(h,144)-((hhv(h,144)-llv(l,144))*0.5));
zlzc3:=(hhv(h,144)-((hhv(h,144)-llv(l,144))*0.382));
PARTLINE(FS3>ref(FS3,1),FS3);
PARTLINE(FS3<ref(FS3,1),FS3);


清凉
input:P(13,0,100);
多:=EMA(C,3),COLORYELLOW;
空:=EMA(C,5),COLOR00FF00;
均衡:=EMA(空,5),COLORWHITE,;
中:=HHV(MA(H,13),13),colorFF9966,Colorgreen,LINETHICK1;
Var4:=(LOW+HIGH+CLOSE)/3;
操作:MA(Var4,5),colorgreen,linethick2;
拉升:=HHV(操作,13),colorgreen,linethick0;
拉升买:=HHV(操作,13)coloryellow,linethick0;
Var1:=((HIGH+LOW+CLOSE)/3-MA((HIGH+LOW+CLOSE)/3,89))/(0.015*AVEDEV((HIGH+LOW+CLOSE)/3,89));
Var2:=MA(Var1,13);
STICKLINE(操作<拉升买,中,拉升买,1,0),COLOR9FBC7D;
强弱分界:=eMA(CLOSE,60), Color438200,LINETHICK3;
f0:=ema(c,5),linethick0;
f1:=sma(f0,3,1);
f2:=sma(f0,5,1);
drawicon(f0>f2,f2,10);
PARTLINE(拉升买,拉升买+0.01),colorgreen,,linethick2;
PARTLINE(操作=拉升买,操作),colorred,linethick3;
STICKLINE(操作>ref(操作,1),操作,操作+0.02,3,0),coloryellow,linethick2;
STICKLINE(拉升>ref(拉升,1),拉升,拉升+0.02,3,0),coloryellow,linethick2;
STICKLINE(操作<拉升买,操作,拉升买,1,0),COLOR9FBC7D;
PARTLINE(中>拉升买,中),colorgreen;
f0:=ema(c,5);
f1:=sma(f0,3,1);
f2:=sma(f0,5,1);
f0:=ema(c,5);
f1:=sma(f0,3,1);
f2:=sma(f0,5,1);
STICKLINE(F0<F2,H,L,1,1),Colorgreen;
STICKLINE(F0<F2,O,C,6,1),Colorgreen;
大趋势:EMA(CLOSE,245),linethick1,COLORred;
Var1:=REF(CLOSE,2);
A2:= SMA(MAX(CLOSE-Var1,0),7,1)/SMA(ABS(CLOSE-Var1),7,1)*100,COLORGREEN,linethick0;
Var2:=REF(CLOSE,1);
Var3:=SMA(MAX(CLOSE-Var2,0),7,1)/SMA(ABS(CLOSE-Var2),7,1)*100;
DRAWICON(A2< REF(A2,1) AND A2>79,操作*1.05,5);
Var1:=1;
Var2:=(CLOSE-MA(CLOSE,P))/MA(CLOSE,P)*100;
Var3:=CLOSE>OPEN AND OPEN-LOW>HIGH-CLOSE;
Var4:=REF(Var2,1)<-20 AND Var3;
Var5:=REF(Var2,1)<-20 AND CLOSE>OPEN AND(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*1000>20;
Var6:=FILTER(Var4 OR Var5,3);
Var7:=OPEN>CLOSE AND HIGH-IF(CLOSE>OPEN,CLOSE,OPEN)>IF(OPEN<CLOSE,OPEN,CLOSE)-LOW;
Var8:=REF(Var2,1)>ABS(-20)AND Var7;
Var9:=REF(Var2,1)>ABS(-20)AND CLOSE<OPEN AND(REF(CLOSE,1)-CLOSE)/REF(CLOSE,1)*1000>20;
VarA:=FILTER(Var8 OR Var9,3);
VarB:=CLOSE>OPEN AND OPEN-LOW>HIGH-CLOSE;
VarC:=REF(Var2,1)<-13 AND Var3;
VarD:=REF(Var2,1)<-13AND CLOSE>OPEN AND(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*1000>20;
VarE:=FILTER(VarC OR VarD,3);
VarF:=OPEN>CLOSE AND HIGH-IF(CLOSE>OPEN,CLOSE,OPEN)>IF(OPEN<CLOSE,OPEN,CLOSE)-LOW;
Var10:=REF(Var2,1)>ABS(-13) AND Var7;
Var11:=REF(Var2,1)>ABS(-13)AND CLOSE<OPEN AND(REF(CLOSE,1)-CLOSE)/REF(CLOSE,1)*1000>20;
Var12:=FILTER(Var10 OR Var11,3);
DRAWICON(VarA*Var1>0,HIGH,2);


趋势环(飞狐)



input: n(13,6,40);
fo:=if(checkuser(1),o,0);
fh:=if(checkuser(1),h,0);
fl:=if(checkuser(1),l,0);
fc:=if(checkuser(1),c,0);
<%

vo=ffl.vardata("fo")
vh=ffl.vardata("fh")
vl=ffl.vardata("fl")
vc=ffl.vardata("fc")
last=ubound(vc)

vc(0)=(vh(0)+vl(0)+2*vc(0))/4
for i=1 to last
vo(i)=(vo(i-1)+vc(i-1))/2
if vo(i)>vh(i) then vh(i)=vo(i) else vh(i)=vh(i)
if vo(i)<vl(i) then vl(i)=vo(i) else vl(i)=vl(i)
vc(i)=(2*vc(i)+vh(i)+vl(i))/4
next

ffl.vardata("fo")=vo
ffl.vardata("fh")=vh
ffl.vardata("fl")=vl
ffl.vardata("fc")=vc


%>
kk:=if(fc>=fo and (fc>=ref(fc,1) or ref(fc,1)>=ref(fo,1)),1,if(fc<fo and (fc<ref(fo,1) or ref(fc,1)<ref(fo,1)),-1,0));
明:(fo+fc)/2,shift1,colorff00;
转:=if(kk=1,min(fc,fo),if(kk=-1,max(fc,fo),if(ref(kk,1)=1,min(fc,fo),if(ref(kk,1)=-1,max(fc,fo),(fc+fo)/2))));
drawnumber(islastbar,明,明,2),shift1;
drawnumber(islastbar,if(fc>fo,明*0.97,明*1.03),转,2),shift1;
中:=ma(c,n);
天:=中+2*stdp(c,n);
罗:=中+stdp(c,n);
地:=中-stdp(c,n);
网:=中-2*stdp(c,n);
mk:=if(kk=1,h,if(kk=-1,c,if(ref(kk,1)=1,h,c)));
cir1:if(max(c,o)>中 and l>地 and 明>地,明+0.2*sqrt(ma((mk+中)*(mk-中),3)),明),colorff00ff;
cir2:if(max(c,o)>中 and l>地 and 明>地,明-0.2*sqrt(ma((mk+中)*(mk-中),3)),明),colorff00ff;
stickline(kk=1,min(fo,fc),min(fo,fc)+abs(fc-fo)*1/8,8,0),colorff;
stickline(kk=1,min(fo,fc)+abs(fc-fo)*1/8,min(fo,fc)+abs(fc-fo)*2/8,8,0),color33ff;
stickline(kk=1,min(fo,fc)+abs(fc-fo)*2/8,min(fo,fc)+abs(fc-fo)*3/8,8,0),color66ff;
stickline(kk=1,min(fo,fc)+abs(fc-fo)*3/8,min(fo,fc)+abs(fc-fo)*4/8,8,0),color99ff;
stickline(kk=1,min(fo,fc)+abs(fc-fo)*4/8,min(fo,fc)+abs(fc-fo)*5/8,8,0),colorbbff;
stickline(kk=1,min(fo,fc)+abs(fc-fo)*5/8,min(fo,fc)+abs(fc-fo)*6/8,8,0),colorccff;
stickline(kk=1,min(fo,fc)+abs(fc-fo)*6/8,min(fo,fc)+abs(fc-fo)*7/8,8,0),coloreeff;
stickline(kk=1,min(fo,fc)+abs(fc-fo)*7/8,min(fo,fc)+abs(fc-fo)*8/8,8,0),colorffff;
stickline(kk=-1,min(fo,fc),min(fo,fc)+abs(fc-fo)*1/8,8,0),colorffff;
stickline(kk=-1,min(fo,fc)+abs(fc-fo)*1/8,min(fo,fc)+abs(fc-fo)*2/8,8,0),colorffee00;
stickline(kk=-1,min(fo,fc)+abs(fc-fo)*2/8,min(fo,fc)+abs(fc-fo)*3/8,8,0),colorffcc00;
stickline(kk=-1,min(fo,fc)+abs(fc-fo)*3/8,min(fo,fc)+abs(fc-fo)*4/8,8,0),colorffaa00;
stickline(kk=-1,min(fo,fc)+abs(fc-fo)*4/8,min(fo,fc)+abs(fc-fo)*5/8,8,0),colorff8800;
stickline(kk=-1,min(fo,fc)+abs(fc-fo)*5/8,min(fo,fc)+abs(fc-fo)*6/8,8,0),colorff6600;
stickline(kk=-1,min(fo,fc)+abs(fc-fo)*6/8,min(fo,fc)+abs(fc-fo)*7/8,8,0),colorff3300;
stickline(kk=-1,min(fo,fc)+abs(fc-fo)*7/8,min(fo,fc)+abs(fc-fo)*8/8,8,0),colorff0000;
stickline(fc>fo,fh,fc,0.4,0),colorff;
stickline(fc>fo,fo,fl,0.4,0),colorff;
stickline(fo>fc,fh,fo,0.4,0),colorffff00;
stickline(fo>fc,fc,fl,0.4,0),colorffff00;
stickline(kk=0 and fc>=fo,fo,fc,8,1),colorff00ff;
stickline(kk=0 and fc<fo,fo,fc,8,0),colorff00ff


清凉
操作:MA(Var4,5),colorgreen,linethick2;
将此项改成
操作:MA(Var4,1),colorgreen,linethick2;
会形成极好顶线


一目
N:52 ,0,100 m:26,0,100 L:9,0,100
参数变为
N:52 ,0,100 m:1,0,100 L:1,0,100
还一目本来面目股票公式 www.hlsm.net

  声明:本站部分内容来自合作媒体及网络,不代表本站观点。本站不对上述言论承担责任。关键字:短波,中波,操作,飞狐,公式

大智慧公式网部分资料来自网络,版权归原作者所有.关键字:指标公式破解,指标公式编写,股票指标公式