i 通达信指标公式,通达信公式,通达信主图指标公式,本栏目包含通达信指标公式,通达信公式,通达信主图指标公式等内容
返回首页-庄家事儿网
.
当前位置:红岭私募 > 通达信公式

公式源码:通达信专用根据布林线做的公式(源码,帖图)(公式)

关键字:通达信指标公式,通达信公式,通达信主图指标公式  来源:红岭私募网hlsm.net
名字自己起(跟据布林线做的公式)
MA5:EMA(CLOSE,5);
MA10:EMA(C,10);
MA20:EMA(CLOSE,20);
VAR1A:=(REF(HIGH,1)+REF(LOW,1))/2;
压力线:MA(CLOSE,20)+2*STD(CLOSE,20);
支撑线:MA(CLOSE,21)-2.2*STD(CLOSE,21),COLORYELLOW;
VAR2A:=CROSS(VAR1A,压力线);
VAR3A:=REF(CLOSE,1);
VAR4A:=SMA(MAX(CLOSE-VAR3A,0),7,1)/SMA(ABS(CLOSE-VAR3A),7,1)*100;
VAR5A:=CROSS(79,VAR4A);
VAR6A:=FILTER(VAR5A,4);
DRAWICON(FILTER(VAR6A OR VAR2A,5),HIGH*1.035,2);
DRAWTEXT(FILTER(VAR6A OR VAR2A,5),HIGH*1.02,'卖'),COLORYELLOW;
VAR7A:=FILTER( MA5>REF(MA5,1)AND MA10>REF(MA10,1)AND MA20>REF(MA20,1)AND MA5<MA10,5);
VAR8A:=FILTER(HHVBARS(H,13)/C>2 AND MA5>REF(MA5,1)AND MA5<MA10,7);
VAR9A:=REF(L,2)<支撑线 AND L>支撑线 AND C>O AND MA5>REF(MA5,1);
DRAWICON(FILTER(VAR7A OR VAR8A OR VAR9A,5)AND VAR4A<45,L,1);
DRAWTEXT(FILTER(VAR7A OR VAR8A OR VAR9A,5)AND VAR4A<45,L,'买'),COLORRED;
DRAWICON(CROSS(10,VAR4A),L,3);
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
涨:STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3,1),COLORRED;
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
跌:STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13
OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),3,0),COLORFF8080;
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
底:STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,0),COLORYELLOW;
VAR1B:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
顶:STICKLINE(VAR1B,REF(CLOSE,1),REF(CLOSE,2),3,0),COLORWHITE;
A:=BARSCOUNT(C);
AH:=HHV(H,72);
AL:=LLV(L,72);
A0:=(AH-AL)/21;
B1:=L-A0;
STICKLINE((A+0)/13=FLOOR((A+0)/13),B1,B1-3*A0,1,0);
DRAWTEXT((A+0)/13=FLOOR((A+0)/13),B1-5.5*A0,'转向'),COLORWHITE;股票公式 www.hlsm.net

附件:

32016.jpg (264.79 KB)

2011-11-22 23:20



  声明:本站部分内容来自合作媒体及网络,不代表本站观点。本站不对上述言论承担责任。关键字:支撑,公式,附件,压力,转向

大智慧公式网部分资料来自网络,版权归原作者所有.关键字:通达信指标公式,通达信公式,通达信主图指标公式